週に一回は書きますよ 月に4つ記事を書けばノルマは満たされます。
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

急に無線が繋らなくなり、しばらくしたら何となく直りました。

経緯

  • 昨日(木曜) aptitude updateおよび safe-upgradeをかけた。そのときにカーネルのバージョンが上がり、再起動を要求された。
  • 再起動したら無線が立ちあがらなくなった。
  • とりあえず放置するも、今朝も無線が起動せず。
    • 何回か再起動をしてもまったく回復しません。

症状はこんなところです。

# ifup wlan0
SIOCSIFFLAGS: Resource temporarily unavailable
Could not set interface 'wlan0' UP
SIOCSIFFLAGS: Resource temporarily unavailable
SIOCSIFFLAGS: Resource temporarily unavailable
Failed to bring up wlan0.

$ dmsg
(snip)
[   11.684379] ath5k_pci 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   11.684393] ath5k_pci 0000:02:00.0: setting latency timer to 64
[   11.684450] ath5k_pci 0000:02:00.0: registered as 'phy0'
[   11.759647] phy0: Selected rate control algorithm 'pid'
[   11.857792] iTCO_vendor_support: vendor-support=0
[   11.903647] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.05
[   11.903782] iTCO_wdt: Found a ICH7-M or ICH7-U TCO device (Version=2, TCOBASE
=0x0460)
[   11.903858] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[   11.947271] ath5k phy0: Atheros AR5414 chip found (MAC: 0xa3, PHY: 0x61)
[   12.107628] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22

(snip)

[   26.245198] ath5k phy0: noise floor calibration timeout (2412MHz)
[   26.245381] ath5k phy0: noise floor calibration timeout (2427MHz)
[   26.590719] ath5k phy0: gain calibration timeout (2427MHz)
[   26.590724] ath5k phy0: can't reset hardware (-11)
[   26.590728] wlan0: Failed to config new SSID to the low-level driver
[   26.935193] ath5k phy0: gain calibration timeout (2427MHz)
[   26.935199] ath5k phy0: can't reset hardware (-11)
[   26.935203] wlan0: Failed to config new BSSID to the low-level driver
[   32.312588] ath5k phy0: gain calibration timeout (2412MHz)
[   32.312595] ath5k phy0: can't reset hardware (-11)
[   32.312599] phy0: failed to set freq to 2412 MHz for scan
[   32.657112] ath5k phy0: gain calibration timeout (2417MHz)
[   32.657116] ath5k phy0: can't reset hardware (-11)

(snip)

どうも起動時に何か障害が起きているようです。ついでに、ath5k_pciというジョブがずっとCPUを100 %食っています。どうみてもおかしいです。

きっかけがアップデートなので、とりあえずカーネルのバージョンを下げてみます。バージョンは2.6.28-11から2.6.28-13に上がっていたので、とりあえず11に戻してみました。

直りました。

dmsgにあったエラーも無くなっています。それ以外は一致。これはレポートをしないといけない予感です。どこに投げればよいのか。

とりあえず最新カーネルで再度立ちあげて、不具合を確認してみます。

最新カーネルでも直りました。何故直ったし。上の通りエラーメッセージの他に変化が無いので何が悪かったのかわかりません。

とりあえずネットワークは使えるので、こうして記事を投稿しています。

スポンサーサイト
コメント
この記事へのコメント
コメントを投稿する
URL:
Comment:
Pass:
秘密: 管理者にだけ表示を許可する
 
トラックバック
この記事のトラックバックURL
http://gusmachine.blog49.fc2.com/tb.php/464-8ed3d3c2
この記事にトラックバックする(FC2ブログユーザー)
この記事へのトラックバック
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。